dbus-daemon: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.600"
Christian Schmitz
2011-12-08 23:13:02 UTC
I am trying to sync the qtek 9100 phone on Opensuse 11.4
Still no sucess but with advances. This email is for contribute a little with
the project.
after package install, i ran
And i get 1 error:
2011-12-08 14:41:50,007 ERROR dbus.proxies : Introspect error
on :1.5:/org/synce/dccm/DeviceManager: dbus.exceptions.DBusException:
org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)"
requested_reply=0 destination=":1.5" (uid=0 pid=9548

into the /var/log/messages i found:
Dec 8 10:36:53 xxxx dbus-daemon: [system] Rejected send message, 1 matched
rules; type="method_call", sender=":1.600" (uid=0 pid=10068 comm="python)
interface="org.freedesktop.DBus.Introspectable" member="Introspect" error
name="(unset)" requested_reply=0 destination=":1.599" (uid=0 pid=9954

When i ran
create_partnership.py "brujamovil" "Contacts,Calendar,Notes,Tasks,Files"
i get
error: failed partnership

I suspect that this error was the origin of my problem and still cant sync,
but at least the errors disapear.

Edit /etc/dbus-1/system.d/org.synce.dccm.conf

When i found:
<policy context="default">
<allow send_destination="org.synce.dccm"

i add the second line showed here:

<policy context="default">
<allow send_type="method_call" />
<allow send_destination="org.synce.dccm"

I see the proyect advance but still is hard for unexperimented users. I think
that if all proyect is compacted into one single RPM (entire synce is not so
heavy) with one configurer will be a grat step.

Regards i will still figthing to sync. Any idea will be appreciated

Christian Schmitz
SCHlabs developers
+54 11 4639-5945
Buenos Aires, Argentina
be free, be linux.